use strict;
my $str = 'Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]';
my $regex = qr/\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}