const regex = /\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[id(\\d*)\\|([а-яА-Яa-zA-ZЁёЙй]*)\\]', 'gmi')
const str = `Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}