#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<div id="cphMain_pnl.*?Items".*?</div>"
Local $sString = "<div id="cphMain_pnlBreakfastItems" class="bp2-wdn-col-one-third">" & @CRLF & _
" <h4>blah blah</h4>" & @CRLF & _
" <span>content</span>" & @CRLF & _
" <span>other content</span>" & @CRLF & _
"</div>" & @CRLF & _
"<div id="cphMain_pnlLunchItems" class="bp2-wdn-col-one-third">" & @CRLF & _
" <h4>blah blah</h4>" & @CRLF & _
" <span>content</span>" & @CRLF & _
" <span>other content</span>" & @CRLF & _
"</div>" & @CRLF & _
"<div id="cphMain_pnlDinnerItems" class="bp2-wdn-col-one-third">" & @CRLF & _
" <h4>blah blah</h4>" & @CRLF & _
" <span>content</span>" & @CRLF & _
" <span>other content</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")