import re
regex = re.compile(r"<div id=\"cphMain_pnl.*?Items\".*?</div>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<div id=\"cphMain_pnlBreakfastItems\" class=\"bp2-wdn-col-one-third\">\n"
" <h4>blah blah</h4>\n"
" <span>content</span>\n"
" <span>other content</span>\n"
"</div>\n"
"<div id=\"cphMain_pnlLunchItems\" class=\"bp2-wdn-col-one-third\">\n"
" <h4>blah blah</h4>\n"
" <span>content</span>\n"
" <span>other content</span>\n"
"</div>\n"
"<div id=\"cphMain_pnlDinnerItems\" class=\"bp2-wdn-col-one-third\">\n"
" <h4>blah blah</h4>\n"
" <span>content</span>\n"
" <span>other content</span>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")