// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)<div id="cphMain_pnl.*?Items".*?</div>"#).unwrap();
let string = "<div id=\"cphMain_pnlBreakfastItems\" class=\"bp2-wdn-col-one-third\">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id=\"cphMain_pnlLunchItems\" class=\"bp2-wdn-col-one-third\">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id=\"cphMain_pnlDinnerItems\" class=\"bp2-wdn-col-one-third\">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}