import Foundation
let pattern = #"<div id="cphMain_pnl.*?Items".*?</div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<div id="cphMain_pnlBreakfastItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlLunchItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlDinnerItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)