using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div id=""cphMain_pnl.*?Items"".*?</div>";
string input = @"<div id=""cphMain_pnlBreakfastItems"" class=""bp2-wdn-col-one-third"">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id=""cphMain_pnlLunchItems"" class=""bp2-wdn-col-one-third"">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id=""cphMain_pnlDinnerItems"" class=""bp2-wdn-col-one-third"">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}