re = /<div id="cphMain_pnl.*?Items".*?<\/div>/m
str = '<div id="cphMain_pnlBreakfastItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlLunchItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlDinnerItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end