package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<div id="cphMain_pnl.*?Items".*?</div>`)
var str = `<div id="cphMain_pnlBreakfastItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlLunchItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>
<div id="cphMain_pnlDinnerItems" class="bp2-wdn-col-one-third">
<h4>blah blah</h4>
<span>content</span>
<span>other content</span>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}