#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$"
Local $sString = "Test, more stuff" & @CRLF & _
"Test, some informattion, more stuff" & @CRLF & _
"test, more stuff (additional information)" & @CRLF & _
"Test, some information, more stuff (addtional information)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)