package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$`)
var str = `Test, more stuff
Test, some informattion, more stuff
test, more stuff (additional information)
Test, some information, more stuff (addtional information)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}