use strict;
my $str = 'Test, more stuff
Test, some informattion, more stuff
test, more stuff (additional information)
Test, some information, more stuff (addtional information)';
my $regex = qr/^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";