using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$";
string substitution = @"";
string input = @"Test, more stuff
Test, some informattion, more stuff
test, more stuff (additional information)
Test, some information, more stuff (addtional information)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}