import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:,(.*?))?,([^()\\n]*)(?: \\((.*?)\\))?$";
final String string = "Test, more stuff\n"
+ "Test, some informattion, more stuff\n"
+ "test, more stuff (additional information)\n"
+ "Test, some information, more stuff (addtional information)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}