const regex = /^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(?:,(.*?))?,([^()\\n]*)(?: \\((.*?)\\))?$', 'gm')
const str = `Test, more stuff
Test, some informattion, more stuff
test, more stuff (additional information)
Test, some information, more stuff (addtional information)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);