$re = '/^(.*?)(?:,(.*?))?,([^()\n]*)(?: \((.*?)\))?$/m';
$str = 'Test, more stuff
Test, some informattion, more stuff
test, more stuff (additional information)
Test, some information, more stuff (addtional information)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;