#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(\d\d)\:(\d\d)\s*$"
Local $sString = "1985.10.25 11:30" & @CRLF & _
                "1985-10-25 11:30" & @CRLF & _
                "11:30" & @CRLF & _
                "  11:30" & @CRLF & _
                "11:30 " & @CRLF & _
                "  11:30  " & @CRLF & _
                "11:30  " & @CRLF & _
                "11:30 1985.10.25" & @CRLF & _
                "aa:bb" & @CRLF & _
                "11:bb" & @CRLF & _
                "aa:22" & @CRLF & _
                "a1:22" & @CRLF & _
                "1a:22" & @CRLF & _
                "1a:3a" & @CRLF & _
                "1a:a3" & @CRLF & _
                "111:30" & @CRLF & _
                "1:2" & @CRLF & _
                "1:20" & @CRLF & _
                "01:2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")