// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(\d\d)\:(\d\d)\s*$").unwrap();
let string = "1985.10.25 11:30
1985-10-25 11:30
11:30
11:30
11:30
11:30
11:30
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}