use strict;
my $str = '1985.10.25 11:30
1985-10-25 11:30
11:30
  11:30
11:30 
  11:30  
11:30  
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2';
my $regex = qr/^\s*(\d\d)\:(\d\d)\s*$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}