import re
regex = re.compile(r"^\s*(\d\d)\:(\d\d)\s*$", flags=re.MULTILINE)
test_str = ("1985.10.25 11:30\n"
"1985-10-25 11:30\n"
"11:30\n"
" 11:30\n"
"11:30 \n"
" 11:30 \n"
"11:30 \n"
"11:30 1985.10.25\n"
"aa:bb\n"
"11:bb\n"
"aa:22\n"
"a1:22\n"
"1a:22\n"
"1a:3a\n"
"1a:a3\n"
"111:30\n"
"1:2\n"
"1:20\n"
"01:2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")