import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\d\\d)\\:(\\d\\d)\\s*$";
final String string = "1985.10.25 11:30\n"
+ "1985-10-25 11:30\n"
+ "11:30\n"
+ " 11:30\n"
+ "11:30 \n"
+ " 11:30 \n"
+ "11:30 \n"
+ "11:30 1985.10.25\n"
+ "aa:bb\n"
+ "11:bb\n"
+ "aa:22\n"
+ "a1:22\n"
+ "1a:22\n"
+ "1a:3a\n"
+ "1a:a3\n"
+ "111:30\n"
+ "1:2\n"
+ "1:20\n"
+ "01:2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}