#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)quote\s*(\d+)"
Local $sString = "sjhsh QUOTE 234566" & @CRLF & _
"sdsds customer call QUote 239876 Call back" & @CRLF & _
"adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio" & @CRLF & _
"QUOTE 657894 customer called for service" & @CRLF & _
"QUOTE 657894 customer called for service QUOTE 657894 customer called for service" & @CRLF & _
"No qte"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")