const regex = new RegExp('(?i)quote\\s*(\\d+)', 'gm')
const str = `sjhsh QUOTE 234566
sdsds customer call QUote 239876 Call back
adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio
QUOTE 657894 customer called for service
QUOTE 657894 customer called for service QUOTE 657894 customer called for service
No qte`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}