// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)quote\s*(\d+)").unwrap();
let string = "sjhsh QUOTE 234566
sdsds customer call QUote 239876 Call back
adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio
QUOTE 657894 customer called for service
QUOTE 657894 customer called for service QUOTE 657894 customer called for service
No qte";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}