import re
regex = re.compile(r"(?i)quote\s*(\d+)", flags=re.MULTILINE)
test_str = ("sjhsh QUOTE 234566\n"
"sdsds customer call QUote 239876 Call back\n"
"adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio\n"
"QUOTE 657894 customer called for service\n"
"QUOTE 657894 customer called for service QUOTE 657894 customer called for service\n"
"No qte")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")