package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)quote\s*(\d+)`)
var str = `sjhsh QUOTE 234566
sdsds customer call QUote 239876 Call back
adsdfh unknown call from customer QUOTE 189067 sdkjsd woieweio
QUOTE 657894 customer called for service
QUOTE 657894 customer called for service QUOTE 657894 customer called for service
No qte`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}