#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b"
Local $sString = "23:55" & @CRLF & _
"-13:21" & @CRLF & _
"+13:21" & @CRLF & _
"1:22" & @CRLF & _
"5:19" & @CRLF & _
"1234412231" & @CRLF & _
"42:48" & @CRLF & _
"2.48" & @CRLF & _
"2:48" & @CRLF & _
"12:159" & @CRLF & _
"gordon" & @CRLF & _
"11:87" & @CRLF & _
"_12:12" & @CRLF & _
"0:0" & @CRLF & _
"0:15" & @CRLF & _
"14:55" & @CRLF & _
"13:00" & @CRLF & _
"" & @CRLF & _
"1:12 11:17" & @CRLF & _
"55:1 15:55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")