use strict;
my $str = '23:55
-13:21
+13:21
1:22
5:19
1234412231
42:48
2.48
2:48
12:159
gordon
11:87
_12:12
0:0
0:15
14:55
13:00
1:12 11:17
55:1 15:55';
my $regex = qr/(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}