package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b`)
var str = `23:55
-13:21
+13:21
1:22
5:19
1234412231
42:48
2.48
2:48
12:159
gordon
11:87
_12:12
0:0
0:15
14:55
13:00
1:12 11:17
55:1 15:55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}