using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b";
string input = @"23:55
-13:21
+13:21
1:22
5:19
1234412231
42:48
2.48
2:48
12:159
gordon
11:87
_12:12
0:0
0:15
14:55
13:00
1:12 11:17
55:1 15:55";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}