// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b").unwrap();
let string = "23:55
-13:21
+13:21
1:22
5:19
1234412231
42:48
2.48
2:48
12:159
gordon
11:87
_12:12
0:0
0:15
14:55
13:00
1:12 11:17
55:1 15:55";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}