const regex = /(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<sign>[-+]?)\\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\\b', 'g')
const str = `23:55
-13:21
+13:21
1:22
5:19
1234412231
42:48
2.48
2:48
12:159
gordon
11:87
_12:12
0:0
0:15
14:55
13:00
1:12 11:17
55:1 15:55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}