import re
regex = re.compile(r"(?<sign>[-+]?)\b(?<hours>2[1-3]|[01][0-9]|[1-9]):(?<minutes>[0-5][0-9])\b")
test_str = ("23:55\n"
"-13:21\n"
"+13:21\n"
"1:22\n"
"5:19\n"
"1234412231\n"
"42:48\n"
"2.48\n"
"2:48\n"
"12:159\n"
"gordon\n"
"11:87\n"
"_12:12\n"
"0:0\n"
"0:15\n"
"14:55\n"
"13:00\n\n"
"1:12 11:17\n"
"55:1 15:55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")