# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\W_])\1+/ /gm;t' <<< "
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y."