re = /([\W_])\1+/m
str = '
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result