#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\W_])\1+"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
".AAA.x.@@+*@#=..xx000..x.. .x.." & @CRLF & _
"x*+Y."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)