use strict;
my $str = '
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y.';
my $regex = qr/([\W_])\1+/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";