const regex = new RegExp('([\\W_])\\1+', 'gm')
const str = `
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);