$re = '/([\W_])\1+/m';
$str = '
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;