using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\W_])\1+";
string substitution = @" ";
string input = @"
.AAA.x.@@+*@#=..xx000..x.. .x..
x*+Y.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}