#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+\.)?(\d{3})+(?=\S+)"
Local $sString = "12345678" & @CRLF & _
"87654321" & @CRLF & _
"" & @CRLF & _
"3.123456" & @CRLF & _
"123456.3"
Local $sSubst = "$1$2,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)