using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\.)?(\d{3})+(?=\S+)";
string substitution = @"$1$2,";
string input = @"12345678
87654321
3.123456
123456.3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}