import re
regex = re.compile(r"^(\d+\.)?(\d{3})+(?=\S+)", flags=re.MULTILINE)
test_str = ("12345678\n"
"87654321\n\n"
"3.123456\n"
"123456.3")
subst = "$1$2,"
result = regex.sub(subst, test_str)
if result:
print(result)