use strict;
my $str = '12345678
87654321
3.123456
123456.3';
my $regex = qr/^(\d+\.)?(\d{3})+(?=\S+)/mp;
my $subst = '$1$2,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";