$re = '/^(\d+\.)?(\d{3})+(?=\S+)/m';
$str = '12345678
87654321
3.123456
123456.3';
$subst = "$1$2,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;