package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`value\":\s*(?:[^;]*;){1}(.*?);`)
var str = `{
"item0": {
"sumstate": {
"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;"
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}