use strict;
my $str = '{
"item0": {
"sumstate": {
"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;"
';
my $regex = qr/value\":\s*(?:[^;]*;){1}(.*?);/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}