const regex = /value\":\s*(?:[^;]*;){1}(.*?);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value\\":\\s*(?:[^;]*;){1}(.*?);', '')
const str = `{
"item0": {
"sumstate": {
"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}