$re = '/value\":\s*(?:[^;]*;){1}(.*?);/';
$str = '{
"item0": {
"sumstate": {
"value": "0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;"
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);