import re
regex = re.compile(r"value\":\s*(?:[^;]*;){1}(.*?);")
test_str = ("{\n"
"\"item0\": {\n"
"\"sumstate\": {\n"
"\"value\": \"0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;\"\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")